Inden opgradering

Før opgradering påbegyndes

Opgradering af installerede versioner af DanDomain Webshop Integration (DWI) kræver lidt forberedelse for at undgå forviklinger senere i forløbet. Der findes en del “hvis” klausuler der besvares nedenfor, samt hvilken handling man skal foretage sig i de tilfælde at disse er opfyldte.

Hvis… Handling
– man har installeret DWI på egen server. Her er det vigtigt, at man selv foretager af-installationen og geninstallerer DWI softwaren. Desuden, er det vigtig at kontrollere at .NET framework version 2.0 er installeret på maskinen*
– der ligger ordrer og kunder der ikke er hentet i den nuværende version. DWI servicen kører normalt hele tiden, hvorfor det er vigtig at stoppe denne i den eksisterende løsning og sørge for at alle data om ordrer og kunder er hentet hjem. Når servicen ikke er startet, vil der ikke blive opdateret data fra shoppen, altså nye ordrer hentes ikke hjem fra shoppen.
– der ligger eksempelvis varer, priser og produktgrupper i DWI, altså generelt data. Husk at vente med at stoppe DWI servicen indtil alle informationer der ønskes opdateret på shoppen er væk fra den temporære DWI database. Stop da økonomisystem med at opdatere også.
– der er foretaget specielle konfigurationer der ønskes bevaret Her kan man med fordel, på den maskine hvor DWI er installeret på, navigere ned til installations mappen hvor DWI er installeret og finde filen:

dwi.config

og gemme denne et sted på maskinen som backup. Her er alle indstillinger der ikke skal opdateres, nøgler osv. gemt og kan findes frem ved behov ved at lave en backup inden af-installation.

– der ikke benyttes DSN connections, men derimod direkte drev sti, til at forbinde til den temporære DWI database Her er det vigtig enten at rette til den nye sti i din software applikation efter re-installation af DWI eller installere DWI i den samme mappe / samme struktur som den tidligere installation.
– der kræves administrator rettigheder på serverne, hvor DWI er installeret for at foretage ændringer Her er det vigtig at have kontakt til vedkommende med adgang til administrator kontoen, da en installation ellers vil fejle og ikke kan gennemføres. Kan en installation ikke gennemføres vil eventuelle tilretninger i eget software heller ikke virke.
– der er lavet tilføjelser til den temporære database som bruges af andre systemer end DWI sammen med DWI Her er det yderst vigtig at den nye database der benyttes efter installation af DWI version 2.0, altså opgradering af DWI 1.4.x til DWI 2.0, også tilrettes med de eventuelle tabeller “de andre systemer” benytter.
– der istedet for Microsoft Access, benyttes Microsoft SQL server til den temporære database Her skal de nye felter der er krævet med DWI version 2.0 tilføjes manuelt. De nye felter, samt komplette felt oversigter er beskrevet i denne hjælp under hovedpunktet “5.0 Datablad”

*På www.microsoft.com findes links til download af .NET framework 2.0.

Hvis man ikke har planer om at benytte de nye tabeller, altså ikke oprette dem i evt. egen DWI database, skal DWI konfigurationen sættes op til ikke at bruge disse.

Vigtigt

Vigtigt af bemærke inden du går igang med at opgradere fra version 1.4.x til 2.0 af DanDomain Webshop Integration (DWI) er om det er et standard system du idag benytter til eksempelvis økonomisystem, specielt designet af Navipartner, Winfinans eller anden software leverandør / samarbejdspartner, eller om DWI benyttes til egen integration af diverse intranet, ERP-systemer, CRM-systemer eller andet.

Bruges DWI idag som en del af et andet produkt fra eksempelvis Navipartner eller Winfinans, bør disse partnere spørges til råds inden opgradering finder sted.

Det er også vigtig at undersøge, hvem der skal foretage opgraderingen / gen-installationen. Specielt hvis DWI normalt kører på egen server, hosted server eller andet.